Nexus Legato problem

Nexus Legato problem

Post by Francois Rober » Wed, 07 Apr 1999 04:00:00



I bolted down the chopper by the skids and gave full throtle the engine
fructuate regardless of my attemp to change mixture from rich to lean no
bubble in the fuel line,15%nitro ,factory kyosho muffler, O S 52 Surpass
engine,went thrue 3quarts of fuel and i also bench ran the engine with
aircraft prop for 1quart for proper breaking-in, What the hell you think
is my problem???                                                  Thanks
in advance Bernie
 
 
 

Nexus Legato problem

Post by MArmitstea » Thu, 08 Apr 1999 04:00:00


Quote:

> I bolted down the chopper by the skids and gave full throtle the engine
> fructuate regardless of my attemp to change mixture from rich to lean no
> bubble in the fuel line,15%nitro ,factory kyosho muffler, O S 52 Surpass
> engine,went thrue 3quarts of fuel and i also bench ran the engine with
> aircraft prop for 1quart for proper breaking-in, What the hell you think
> is my problem???                                                  Thanks
> in advance Bernie

I don't really know what you mean but i'll guess.If you have owned a 2
Stroke heli and this is your first 4Stroke heli,don't attempt to tune
the main needle the same as you would a 2 Stroke,4strokes don't like it

     You said you've got the heli bolted down,presumably to tune the
main needle at full throttle,i wouldn't do it this way as it overloads
the engine at max pitch throttle,but anyway how you check it is up to
you.

At any rate you make the adjustments on the main need1e only 1 click at
a time and wait a couple of seconds after every click for the mixture to
re-stabilise,if you try to rush the procedure  you'll just fluctuate
from spluttering too rich to engine quitting when you get it too lean
.Other than this,check you are using a Type "F" plug,the engine may not
be fully run in and may not hold a leaner mixture just yet,so leave it
rich for a while.The tappets should be checked too after it has run 1/2
to 1HR.Also the 52 Surpass comes from the factory with the air bleed
***set for running in purposes so you may need to adjust that too.

   I'm not too faimiliar with the Nexus/Legato's,but if  the tank is
much higher than the centre line of the carburettor,OS Surpass's in
particular don't like it and it makes them a bastard to tune
properly,what usually happens is the engine sounds good at first then
starts to splutter rich again because the head of fuel is trying to
flood it all the time.

Martin

 
 
 

Nexus Legato problem

Post by High- » Thu, 08 Apr 1999 04:00:00


I have the Legato as well.
Do NOT go above half stick when spinning it up.
The 52 vibrates a lot, so keep an eye on the header pipe. IT WILL eventually
crack.
If it does crack and leaks air, then you will get an inconsistent amount of
pressure to the fuel tank and the engine will not run properly.

I've been through a lot with this setup and finally gave up and replaced the
52 with the 32sx.  It made a HUGE difference (although I really loved the
sound of the 52).  But if you choose to stick with it, feel free to email me
and I can give you a lot more advice on it.



I bolted down the chopper by the skids and gave full throtle the engine
fructuate regardless of my attemp to change mixture from rich to lean no
bubble in the fuel line,15%nitro ,factory kyosho muffler, O S 52 Surpass
engine,went thrue 3quarts of fuel and i also bench ran the engine with
aircraft prop for 1quart for proper breaking-in, What the hell you think
is my problem???                                                  Thanks
in advance Bernie