ECO PICCOLO IKARUS Problem

ECO PICCOLO IKARUS Problem

Post by Harry Jone » Thu, 10 Feb 2000 04:00:00



Hi

Have just built Piccolo but it seems there is not enough thrust from the
tail rotor,
The  tail rotor spins round freely but does not counteract the main rotor
torque, Mixing is switched off on the TX (RD6000) and adjustment of mixing
on the Piccoboard does not help even at maximum neither does Gyro gain
adjustments.
The tail rotor speed does inrease with stick movement and with adjustments
to the Piccoboard but still not enough.

Any Help appreciated

Harry

 
 
 

ECO PICCOLO IKARUS Problem

Post by rchelipi.. » Thu, 10 Feb 2000 04:00:00


Your tailrotor motor is spinning in the pinion gear. This is a common
Piccolo problem. Remove the gear, roughen up the motor shaft with
medium grid sandpaper or a file and reglue it with epoxy or CA.

Matt



Quote:
> Hi

> Have just built Piccolo but it seems there is not enough thrust from
the
> tail rotor,
> The  tail rotor spins round freely but does not counteract the main
rotor
> torque, Mixing is switched off on the TX (RD6000) and adjustment of
mixing
> on the Piccoboard does not help even at maximum neither does Gyro gain
> adjustments.
> The tail rotor speed does inrease with stick movement and with
adjustments
> to the Piccoboard but still not enough.

> Any Help appreciated

> Harry

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

ECO PICCOLO IKARUS Problem

Post by Harry Jone » Thu, 10 Feb 2000 04:00:00


Thanks Matt
Just checked and you are 100% right

Regards
Harry


Quote:
> Your tailrotor motor is spinning in the pinion gear. This is a common
> Piccolo problem. Remove the gear, roughen up the motor shaft with
> medium grid sandpaper or a file and reglue it with epoxy or CA.

> Matt



> > Hi

> > Have just built Piccolo but it seems there is not enough thrust from
> the
> > tail rotor,
> > The  tail rotor spins round freely but does not counteract the main
> rotor
> > torque, Mixing is switched off on the TX (RD6000) and adjustment of
> mixing
> > on the Piccoboard does not help even at maximum neither does Gyro gain
> > adjustments.
> > The tail rotor speed does inrease with stick movement and with
> adjustments
> > to the Piccoboard but still not enough.

> > Any Help appreciated

> > Harry

> Sent via Deja.com http://www.deja.com/
> Before you buy.

 
 
 

ECO PICCOLO IKARUS Problem

Post by Paul Goe » Thu, 10 Feb 2000 04:00:00


Quote:

>Your tailrotor motor is spinning in the pinion gear. This is a common
>Piccolo problem. Remove the gear, roughen up the motor shaft with
>medium grid sandpaper or a file and reglue it with epoxy or CA.

>Matt

I had the same problem and I did the same thing.  I also made sure
that there was CA in the pinion shaft hole, and I'm not sure there was
much the first time.  Put a drop on the end of the pinion (I didn't
want to risk it on the shaft) and work it in with a piece of wire.  

BTW, I think the tail rotor motors are the same as the motors from the
little foam B2?  I have several that I bought as spares, and they seem
to be the same motor.  If so, they are $12 for two from Hobby Lobby.  

Paul Goelz
Rochester Hills, MI
pgoelz at eaglequest dot com

 
 
 

ECO PICCOLO IKARUS Problem

Post by Guillaume Hasto » Fri, 11 Feb 2000 04:00:00


What motors do you guys use on your Piccolo helis ? speed 280 ? speed 300 ?
thanks :-)

Guillaume

 
 
 

ECO PICCOLO IKARUS Problem

Post by Timothy Morri » Sat, 12 Feb 2000 04:00:00


I use the stock motor which is a Mabuchi 280 - not sure of the winding. I
think mine has given up after a very short time - flight time is down to 3
mins - was over five when it was new. I've ordered another, but thinking
about it a speed 300 is probably a better bet. Do you know of a web site
that lists its stats?

--
Tim.
(Note the change of email address, but you'll still need to change .us to
.uk if replying by email)


Quote:
> What motors do you guys use on your Piccolo helis ? speed 280 ? speed 300
?
> thanks :-)

> Guillaume

 
 
 

ECO PICCOLO IKARUS Problem

Post by Nick Muell » Sat, 12 Feb 2000 04:00:00


Quote:

> but thinking
> about it a speed 300 is probably a better bet.

I can only warn you of trying this. I got his "good" tip from someone
who claimed it works, but in reality never tried it. Here's the story
why you shouldn't do it:
It bought a speed 300 and it fitted well. I tried a bit holding the
piccolo in the hand wether it works, and it seemed OK. Next, I tried a
hoover. It lifted well, all sounded OK. It put in more pitch to get out
of the ground effect and then it happened. The LED of the PiccoBoard
went off, the rear motor started to spinn on full throttle. My Piccolo
turned like mad, only thing I could do was to let it drop down.
I was able to reproduce the described effekt: As soon as the motor draws
more than a certain amount of power, the LED will go off and the rear
motor will go to full speed. This will also destroi the expensive rear
motor.

Nick
--
Nick Mller

http://www.logictools.de

 
 
 

ECO PICCOLO IKARUS Problem

Post by Martin Lu » Mon, 14 Feb 2000 04:00:00




Quote:

>> but thinking
>> about it a speed 300 is probably a better bet.

I am going to give the Kyosho DMC20BB a try later.
It is better than the 280 ,  11 gms lighter, more thrust
less amps(longer flight) .  You can get that motor
from Tower for USD20.  I use it on my IFO and it
flys for 5+minutes and can hover with it.
 
 
 

ECO PICCOLO IKARUS Problem

Post by Nick Muell » Mon, 14 Feb 2000 04:00:00


Quote:

> I am going to give the Kyosho DMC20BB a try later.

Let us hear wether it workx :-)

TIA,
Nick

--
Nick Mller

http://www.logictools.de

 
 
 

ECO PICCOLO IKARUS Problem

Post by Nick Muell » Sat, 04 Mar 2000 04:00:00


Quote:

> I am going to give the Kyosho DMC20BB a try later.

Any experiences in the meantime?

regards,
Nick
--
Nick Mller

http://www.logictools.de

 
 
 

ECO PICCOLO IKARUS Problem

Post by Martin L » Mon, 06 Mar 2000 04:00:00




Quote:

>> I am going to give the Kyosho DMC20BB a try later.

>Any experiences in the meantime?

Still gets no statisfaction from the 280 yet, I will
change over once I get it to fly properly so that
I can compare. I fly with 250AA and flight time
is only 2-3 minutes , I still find the tail unreliable,
especially flying circuit..it would not turn solid...
wishy washy..
 
 
 

ECO PICCOLO IKARUS Problem

Post by Nick Muell » Mon, 06 Mar 2000 04:00:00



Quote:
> I fly with 250AA and flight time is only 2-3 minutes ,

With the stock motor? Can't be! You really should get 4:00 to 4:30. Try
it without canopy.

Please keep us informed about the Kyosho motor!
thanks,
Nick

--
Nick Mller

http://www.logictools.de